import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#([\\w\\W]*?);";
final String string = "#first line of text;\n"
+ "#second line of text;\n"
+ "#third line could easy \n"
+ "be on a new line;\n"
+ "#forth etc;\n"
+ "#this could (#hi,#hi,#hi) also \n"
+ "happen though:));\n"
+ "#so.... any idea;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}