using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^(\w+)=|\G(?!^))(\w+)(?:,|$)";
string input = @"Something=Item1,Item2,Item3
someOtherThing=Some_Item
Something=";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}