re = /(?:^(\w+)=|\G(?!^))(\w+)(?:,|$)/m
str = 'Something=Item1,Item2,Item3
someOtherThing=Some_Item
Something='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end