$re = '/(?:^(\w+)=|\G(?!^))(\w+)(?:,|$)/m';
$str = 'Something=Item1,Item2,Item3
someOtherThing=Some_Item
Something=';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);