const regex = new RegExp('(?<=\\"fileAssetId\\":\\")[a-fA-F0-9-]+?(?=\\")|(?<=\\"filename\\":\\").+?(?=\\")', 'g')
const str = `'{"d":{"__type":"WikiFileNodeContent:http:\\/\\/samplesite.com.u\\/ns\\/business\\/wiki","author":null,"description":null,"fileAssetId":"034b9317-60d9-45c2-b6d6-0f24b59e1991","filename":"Reports.pdf"},"createdBy":1531,"createdByUsername":"John Cash","icon":"\\/Assets10.37.5.0\\/pix\\/16x16\\/page_white_acrobat.png","id":3041, "filename":"test", "inheritedPermissions":false,"name":"map","permissions":[23,87,35,49,65],"type":3,"viewLevel":2},{"__type":"WikiNode:http:\\/\\/samplesite.com.au\\/ns\\/business\\/wiki","children":[],"content"'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}