package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z0-9]{3,7}(?:[ -][A-Za-z0-9]{3,7}){0,3}\b`)
var str = `32ah3af
32ahPP-A2ah3af
3A63af-3HHx3B-APe5y5-9OPiis
3A63af 3HHx3B APe5y5 9OPiis
325df j344j 25hi245bib245245hj`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}