use strict;
my $str = '32ah3af
32ahPP-A2ah3af
3A63af-3HHx3B-APe5y5-9OPiis
3A63af 3HHx3B APe5y5 9OPiis
325df j344j 25hi245bib245245hj';
my $regex = qr/^[A-Za-z0-9]{3,7}(?:[ -][A-Za-z0-9]{3,7}){0,3}\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}