$re = '/^[A-Za-z0-9]{3,7}(?:[ -][A-Za-z0-9]{3,7}){0,3}\b/m';
$str = '32ah3af
32ahPP-A2ah3af
3A63af-3HHx3B-APe5y5-9OPiis
3A63af 3HHx3B APe5y5 9OPiis
325df j344j 25hi245bib245245hj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);