const regex = /(.+?\t)(.+?\t)(.+?\t)(.+?\t)(.+?\t)(.+?\t)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+?\\t)(.+?\\t)(.+?\\t)(.+?\\t)(.+?\\t)(.+?\\t)', 'g')
const str = `2013-63 (LM63 LSF) Mini Cooper Convertible 1.6 In Black, 31,298 Miles, One Owner From New £9,995 Petrol £130 TAX
`;
const subst = `$2 $1$3$4$5$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);