const regex = /([a-zA-Z]+) \1 \1 (\w+) \2 \2 (boat) \3 \3/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z]+) \\1 \\1 (\\w+) \\2 \\2 (boat) \\3 \\3', 'g')
const str = `row row row your your your boat boat boat
any any any word word word boat boat boat`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}