$re = '/([a-zA-Z]+) \1 \1 (\w+) \2 \2 (boat) \3 \3/';
$str = 'row row row your your your boat boat boat
any any any word word word boat boat boat';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);