import Foundation
let pattern = #"([a-zA-Z]+) \1 \1 (\w+) \2 \2 (boat) \3 \3"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
row row row your your your boat boat boat
any any any word word word boat boat boat
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)