#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{([^)]+)\}"
Local $sString = "input {" & @CRLF & _
" name: "abc"," & @CRLF & _
" age: "20"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"filter {" & @CRLF & _
" name: "pqr"," & @CRLF & _
" age: "25"" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")