$re = '/\{([^)]+)\}/';
$str = 'input {
name: "abc",
age: "20"
}
filter {
name: "pqr",
age: "25"
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);