using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{([^)]+)\}";
string input = @"input {
name: ""abc"",
age: ""20""
}
filter {
name: ""pqr"",
age: ""25""
}
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}