// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(\bgpa[ :]+)?(\d+(?:\.\d+)?)[/\d. ]{0,6}(?(1)| *gpa\b)").unwrap();
let string = "GPA 3.75/4.00
GPA 3.75/4.0
GPA 3.75 /4.0
GPA 3.75 / 4.0
GPA 3.7 / 4 aaa
Major GPA: 3.6/4.0
GPA 3.1
GPA 3
some text GPA 3
3.25/4.0 GPA
some text 3.26 / 4.0 GPA
Minor in Art and Technology - 3.5/4.0 GPA aaaa
Minor in Art and Technology - 3.5 / 4.3 GPA aaaa
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}