import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=_)[^_]+(?=\\.txt)";
final String string = "1994_post_elections_Mandela.txt\n"
+ "1994_pre_elections_deKlerk.txt\n"
+ "1995_Mandela.txt\n"
+ "1996_Mandela.txt\n"
+ "1997_Mandela.txt\n"
+ "1998_Mandela.txt\n"
+ "1999_post_elections_Mandela.txt\n"
+ "1999_pre_elections_Mandela.txt\n"
+ "2000_Mbeki.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}