import re
regex = re.compile(r"(?<=_)[^_]+(?=\.txt)", flags=re.MULTILINE)
test_str = ("1994_post_elections_Mandela.txt\n"
"1994_pre_elections_deKlerk.txt\n"
"1995_Mandela.txt\n"
"1996_Mandela.txt\n"
"1997_Mandela.txt\n"
"1998_Mandela.txt\n"
"1999_post_elections_Mandela.txt\n"
"1999_pre_elections_Mandela.txt\n"
"2000_Mbeki.txt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")