re = /(?<=_)[^_]+(?=\.txt)/m
str = '1994_post_elections_Mandela.txt
1994_pre_elections_deKlerk.txt
1995_Mandela.txt
1996_Mandela.txt
1997_Mandela.txt
1998_Mandela.txt
1999_post_elections_Mandela.txt
1999_pre_elections_Mandela.txt
2000_Mbeki.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end