#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^.]*.[^.]*.[^.]*.[^.]*.[^.]*.([^.]*+)"
Local $sString = "cengage.prod.SSO/OLR.CMP.commerce.CMP-COMMERCE-PROD-5.5.10.proxy" & @CRLF & _
"cengage.stage.aplia.CMP.aplia.stage.proxy" & @CRLF & _
"cengage.stage.CMP.CMP.shared.base.proxy" & @CRLF & _
"cengage.performance.SSO/OLR.CMP.commerce.CMP-COMMERCE-LOAD-5.5.10.proxy" & @CRLF & _
"cengage.performance.Core-Systems.CMP.shared.DT-TESTING.proxy" & @CRLF & _
"cengage.stage.MindTap.CMP.mindtap.5.1.17-build.1.1.proxy" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")