// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^.]*.[^.]*.[^.]*.[^.]*.[^.]*.([^.]*+)").unwrap();
let string = "cengage.prod.SSO/OLR.CMP.commerce.CMP-COMMERCE-PROD-5.5.10.proxy
cengage.stage.aplia.CMP.aplia.stage.proxy
cengage.stage.CMP.CMP.shared.base.proxy
cengage.performance.SSO/OLR.CMP.commerce.CMP-COMMERCE-LOAD-5.5.10.proxy
cengage.performance.Core-Systems.CMP.shared.DT-TESTING.proxy
cengage.stage.MindTap.CMP.mindtap.5.1.17-build.1.1.proxy
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}