const regex = /^[^.]*.[^.]*.[^.]*.[^.]*.[^.]*.([^.]*+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^.]*.[^.]*.[^.]*.[^.]*.[^.]*.([^.]*+)', 'gm')
const str = `cengage.prod.SSO/OLR.CMP.commerce.CMP-COMMERCE-PROD-5.5.10.proxy
cengage.stage.aplia.CMP.aplia.stage.proxy
cengage.stage.CMP.CMP.shared.base.proxy
cengage.performance.SSO/OLR.CMP.commerce.CMP-COMMERCE-LOAD-5.5.10.proxy
cengage.performance.Core-Systems.CMP.shared.DT-TESTING.proxy
cengage.stage.MindTap.CMP.mindtap.5.1.17-build.1.1.proxy
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}