using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+\s+[-]\s+.*?(?=\s+-)|\d+\s+[-].*)";
string input = @"Opcao 06 invalida - nao corresponde ao formato";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}