$re = '/(\d+\s+[-]\s+.*?(?=\s+-)|\d+\s+[-].*)/m';
$str = 'Opcao 06 invalida - nao corresponde ao formato';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);