re = /(\d+\s+[-]\s+.*?(?=\s+-)|\d+\s+[-].*)/m
str = 'Opcao 06 invalida - nao corresponde ao formato'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end