using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"CNPJ\s+[-]\s+(\d+)";
string input = @"CNPJ - 24414873000109";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}