#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\=\=\s*[Ff]onti\s*\=\=)(?!\=+)"
Local $sString = "== Fonti ==" & @CRLF & _
"" & @CRLF & _
"==Fonti== a" & @CRLF & _
" == Fonti ==" & @CRLF & _
"test == fonti ==" & @CRLF & _
"==fonti==" & @CRLF & _
"== fonti ==" & @CRLF & _
"=fonti=" & @CRLF & _
"fonti" & @CRLF & _
"Fonti" & @CRLF & _
"==Fonti===" & @CRLF & _
"==Fonti===" & @CRLF & _
"===Fonti===" & @CRLF & _
"====Fonti====" & @CRLF & _
"" & @CRLF & _
"// regex per sostituire "Fonti con "Bibliografia""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")