const regex = /(\=\=\s*[Ff]onti\s*\=\=)(?!\=+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\=\\=\\s*[Ff]onti\\s*\\=\\=)(?!\\=+)', 'g')
const str = `== Fonti ==
==Fonti== a
== Fonti ==
test == fonti ==
==fonti==
== fonti ==
=fonti=
fonti
Fonti
==Fonti===
==Fonti===
===Fonti===
====Fonti====
// regex per sostituire "Fonti con "Bibliografia"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}