$re = '/(\=\=\s*[Ff]onti\s*\=\=)(?!\=+)/';
$str = '== Fonti ==
==Fonti== a
== Fonti ==
test == fonti ==
==fonti==
== fonti ==
=fonti=
fonti
Fonti
==Fonti===
==Fonti===
===Fonti===
====Fonti====
// regex per sostituire "Fonti con "Bibliografia"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);