#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Session (Start|Close): (\w{3} \w{3} \d{2} \d{2}:\d{2}:\d{2} \d{4})"
Local $sString = "Session Close: Fri Oct 30 21:35:44 1998" & @CRLF & _
"" & @CRLF & _
"Session Start: Fri Oct 30 21:39:05 1998" & @CRLF & _
"*** Now talking in #östersund" & @CRLF & _
"Session Close: Fri Oct 30 21:40:48 1998" & @CRLF & _
"" & @CRLF & _
"Session Start: Fri Oct 30 21:41:02 1998" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")