using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\d+$)[^`~!@#$%^&*()=+_[\]{}\\|;:.'"",<>\/?\n]{1,15}$";
string input = @"some
1345436
folder name her";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}