$re = '/^(?!\d+$)[^`~!@#$%^&*()=+_[\]{}\\\\|;:.\'",<>\/?\n]{1,15}$/m';
$str = 'some
1345436
folder name her';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);