re = /^(?!\d+$)[^`~!@#$%^&*()=+_[\]{}\\|;:.'",<>\/?\n]{1,15}$/m
str = 'some
1345436
folder name her'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end