import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/*";
final String string = "website.com/\n"
+ "website.com/Search/2343-5456-3423-5675\n"
+ "website.com/Availability?value=abc&value=123&step=1\n"
+ "website.com/Booking/Index/444-333-222-111\n"
+ "website.com/subdomain/\n"
+ "website.com\n"
+ "website.com?value=abc\n"
+ "website.com/Booking/Indexer\n"
+ "website.com/Booking/Index\n"
+ "website.com/Booking/Index?value=abc\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}