re = /\/*/m
str = 'website.com/
website.com/Search/2343-5456-3423-5675
website.com/Availability?value=abc&value=123&step=1
website.com/Booking/Index/444-333-222-111
website.com/subdomain/
website.com
website.com?value=abc
website.com/Booking/Indexer
website.com/Booking/Index
website.com/Booking/Index?value=abc
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end