import Foundation
let pattern = #"/*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
website.com/
website.com/Search/2343-5456-3423-5675
website.com/Availability?value=abc&value=123&step=1
website.com/Booking/Index/444-333-222-111
website.com/subdomain/
website.com
website.com?value=abc
website.com/Booking/Indexer
website.com/Booking/Index
website.com/Booking/Index?value=abc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)