package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)(?:[({[])(.*?[mM]ix|.*?[eE]dit|.*?[vV]ersion|.*?[aA]coustic)(?:[)}\]])`)
var str = `SongName (Ft. Artist2) (MixArtist Remix)
SongName (Ft. Artist2) {MixArtist Remix}
SongName (Ft. Artist2) [MixArtist Remix]
SongName (Ft. Artist2) (MixArtist Remix}
SongName (Ft. Artist2) {MixArtist Remix]
Summer Days (feat. Macklemore & Patrick Stump of Fall Out Boy) (Junior Sanchez Remix)`
var substitution = "$1[$2]"
fmt.Println(re.ReplaceAllString(str, substitution))
}