import Foundation
let pattern = #"(.*)(?:[({[])(.*?[mM]ix|.*?[eE]dit|.*?[vV]ersion|.*?[aA]coustic)(?:[)}\]])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SongName (Ft. Artist2) (MixArtist Remix)
SongName (Ft. Artist2) {MixArtist Remix}
SongName (Ft. Artist2) [MixArtist Remix]
SongName (Ft. Artist2) (MixArtist Remix}
SongName (Ft. Artist2) {MixArtist Remix]
Summer Days (feat. Macklemore & Patrick Stump of Fall Out Boy) (Junior Sanchez Remix)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1[$2]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)