$re = '/(.*)(?:[({[])(.*?[mM]ix|.*?[eE]dit|.*?[vV]ersion|.*?[aA]coustic)(?:[)}\]])/m';
$str = 'SongName (Ft. Artist2) (MixArtist Remix)
SongName (Ft. Artist2) {MixArtist Remix}
SongName (Ft. Artist2) [MixArtist Remix]
SongName (Ft. Artist2) (MixArtist Remix}
SongName (Ft. Artist2) {MixArtist Remix]
Summer Days (feat. Macklemore & Patrick Stump of Fall Out Boy) (Junior Sanchez Remix)';
$subst = "$1[$2]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;