using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=prefix\()"".*""(?=\))";
string input = @"x = 'prefix(""hello"")'
y = 'prefix(""hi"")'
z = 'prefix(""hey"")'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}