re = /(?<=prefix\()".*"(?=\))/m
str = 'x = \'prefix("hello")\'
y = \'prefix("hi")\'
z = \'prefix("hey")\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end