$re = '/(?<=prefix\()".*"(?=\))/m';
$str = 'x = \'prefix("hello")\'
y = \'prefix("hi")\'
z = \'prefix("hey")\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);