re = /\b(váš|Váš|náš|Náš)\b/
str = 'Náš počítač je ideální společník na cesty.náš.dsfsdf/efzs'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end