using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((Jan(?:uary|\.)?|Feb(?:ruary|\.)?|Mar(?:ch|\.)?|Apr(?:il|\.)?|May|Jun(?:e|\.)?|Jul(?:y|\.)?|Aug(?:ust|\.)?|Sep(?:tember|\.)?|Oct(?:ober|\.)?|Nov(?:ember|\.)?|Dec(?:ember|\.)?) \d{1,2},? \d{4})";
string input = @"Jan. 12, 2013
Jan 12 2013
Dec. 12, 2013
December 12 2013
Jan. 12, 2013
Jan 12 2013
January 12 2013";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}