$re = '/((Jan(?:uary|\.)?|Feb(?:ruary|\.)?|Mar(?:ch|\.)?|Apr(?:il|\.)?|May|Jun(?:e|\.)?|Jul(?:y|\.)?|Aug(?:ust|\.)?|Sep(?:tember|\.)?|Oct(?:ober|\.)?|Nov(?:ember|\.)?|Dec(?:ember|\.)?) \d{1,2},? \d{4})/m';
$str = 'Jan. 12, 2013
Jan 12 2013
Dec. 12, 2013
December 12 2013
Jan. 12, 2013
Jan 12 2013
January 12 2013';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);