import re
regex = re.compile(r"((Jan(?:uary|\.)?|Feb(?:ruary|\.)?|Mar(?:ch|\.)?|Apr(?:il|\.)?|May|Jun(?:e|\.)?|Jul(?:y|\.)?|Aug(?:ust|\.)?|Sep(?:tember|\.)?|Oct(?:ober|\.)?|Nov(?:ember|\.)?|Dec(?:ember|\.)?) \d{1,2},? \d{4})", flags=re.MULTILINE)
test_str = ("Jan. 12, 2013\n"
"Jan 12 2013\n"
"Dec. 12, 2013\n"
"December 12 2013\n"
"Jan. 12, 2013\n"
"Jan 12 2013\n"
"January 12 2013")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")