using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[\s\S]*)(\{.*)";
string input = @"{Hello}, [123:456] (Test). This is stample data used to answer a
question {Hello2} [Ch.8 p. 87";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}