package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[\s\S]*)(\{.*)`)
var str = `{Hello}, [123:456] (Test). This is stample data used to answer a
question {Hello2} [Ch.8 p. 87`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}