using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z](?:[a-z0-9@()\[\]{}._\-!#$%&'*+\/=?^`|~]|\s[A-Z0-9@()\[\]{}._\-!#$%&'*+\/=?^`|~])*$";
string input = @"D#-' -.1424124123
a
A 9jasvc
Adas s
A12334-# AdadA";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}