import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z](?:[a-z0-9@()\\[\\]\\{\\}._\\-!#$%&'*+\\/=?^`|~]|\\s[A-Z0-9@()\\[\\]\\{\\}._\\-!#$%&'*+\\/=?^`|~])*$";
final String string = "D#-' -.1424124123\n"
+ "a\n\n"
+ "A 9jasvc\n\n"
+ "Adas s\n\n"
+ "A12334-# AdadA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}